Jump to content
Kai Yagami

Quest Fail - Ring Of The Wise King Quest

Recommended Posts

The quest to getting the Ring of the Wise King (http://irowiki.org/wiki/Ring_of_the_Wise_King) cannot be done, cause there is a problem to get past the part of the Red/Blue Jewel (you can´t get them both/one dissapears/etc) and this problem isn´t solved for a couple of years (I looked in the forum an lots of people got the same issue)
I want the Ring so I can´t make the chained quests.....
but there isn´t a way to get it in the game....

Can I have the ring without the quest or get this quest fixed???

Share this post


Link to post
Share on other sites

I already did this quest twice and it worked for me. Maybe you just have to keep trying until you get the item needed.

Share this post


Link to post
Share on other sites

That´s weird!
I killed all the bugs, and took both gems, but I only have the Blue one (I had room on myself)...
And both spots keep telling me that I already have the gems :S

And no, I didn´t tried it with another char.....
I followed every step from the iRO Wiki link, but I don´t have the RED GEM....
And now I don´t know what to do...... :S


Abril, que me recomendas que haga?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×