Jump to content
  • 0
Sign in to follow this  
aferinsinus

Gatheringro Account Activation - This Site Can’T Provide A Secure Connection

Question

Hi all

I just registered to GatheringRo and tried to activate my account to start playing.

However the activation link that has been sent to my e mail address has a problem. No matter which browser i used i can't connect to activation link due to security protocol issues. Browsers simply don't let me. I tried resending activation link and tried again, same result.

The errors:

Google Chrome: This site can't provide a secure connection.

Mozilla Firefox: Secure Connection Failed

Microsoft Edge: Hmm, we can't reach this page

Thank you in advance.

Sorry for duplicate topic. I dont know why it happened.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

I am glad it worked out for you. Don't hesitate to pm me any questions you might have either here on the forums or when you see me ingame

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×